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Minimum Requirements 
 

Viewing Requirements 
 

•  A device capable of connecting to the internet 
•  Java compatible browser, email reader or other java compatible 

software application 
•  Sound generating hardware (i.e. computer sound card)  
•  Sound producing hardware (i.e. speakers or headphones) 

 
On a PC 

 
o Java compatible browser  
o 28.8 or faster Internet connection  
o Win 95,98,NT or above  
o Sound card  
o Pentium 166Mhz CPU or better  
o 32MB RAM  
o 500KB hard disk space  

 
On a Mac 

 
o Java compatible browser  
o 28.8 or faster Internet connection  
o PowerPC Processor  
o MacOS 7.5 or later  
o 4MB application RAM  
o 1MB hard disk space 

 
Encoding/Creation Process Requirements 

 
•  Java compatible browser 
•  Text editor software for inserting applet code 
•  28.8 or faster internet connection 
•  Win 95,98,NT or above 
•  Sound card 
•  Pentium 166Mhz CPU or better 
•  32MB RAM 
•  Hard disk storage for encoded content 

 
Serving Requirements 

 
•  Any standard web server software 

o Adhere to minimum requirements as set out by your web 
server software developer 

•  Any standard web server hardware 
o Adhere to minimum requirements as set out by your web 

server hardware developer 
•  Bandwidth – as with any web server, the more bandwidth you have 

available, the more visitors you can serve.   
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Java Compatibility 
 

In order to hear AudioClipstream™, your browser needs the following:  
 

•  Java Virtual Machine (VM) (this is stock in most browsers)  
•  The Java option enabled  

 
AudioClipstream™ supports most 3.x and higher browsers.  If you or your 
website visitors are seeing text instead of the AudioClipstream™ player, Java 
and JavaScript must be enabled in the browser. 
 
NOTE: For Macintosh users MRJ required (Macintosh OS Runtime for Java).  
Currently the only browser which supports the MRJ is MS IE4.5 or higher. 

 
Enabling Browsers to View AudioClipstream™ 

 
Netscape Navigator 3.x and Higher 

 
1. From the menu bar, choose Options > Network Preferences.  
2. Select the Languages tab.  
3. Check boxes labeled Enable Java and Enable JavaScript.  
4. If you are using Netscape Navigator 4.x: 
5. From the menu bar, choose Edit > Preferences.  
6. Select the Advanced category.  
7. Check boxes labeled Enable Java and Enable JavaScript.  

 
NOTE: If your display is set to greater than 16 bit color, you will see 
TEXT instead of a AudioClipstream™ player on most ads viewed in 
Netscape 4.x. 

 
Internet Explorer 3.x and Higher 

 
1. From the menu bar, choose View > Options.  
2. Select the Security tab.  
3. Check the boxes labeled Run ActiveX scripts and Enable Java 

programs.  
4. If you are using Internet Explorer 4.x: 
5. From the menu bar, choose View > Internet Options.  
6. Select the Security tab.  
7. Set your security level to either Medium or Low.  
8. If you are using Internet Explorer 5.x: 
9. From the menu bar, choose Tools > Internet Options.  
10. Select the Security tab.  
11. Use the slider to set your security level to either Medium, 

Medium-low or Low.  
 

Enabling Java in Email Clients 
 

Eudora 
 

1. From the menu bar, choose Tools > Options.  
2. In the Options window, scroll down and choose Viewing Mail  
3. In the Viewing Mail box, make sure that "Allow executables in 

HTML content" is checked  
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Outlook 

 
1. From the menu bar, choose Tools > Internet Options.  
2. Select Receive Email tab  
3. Make sure that HTML is enabled as the email format to be sent 

(also means what format email is read in)  
 

Note: Outlook Express users are unable to view Java content 
 

Netscape Messenger 
 

1. From the menu bar, choose Edit > Preferences  
2. Select Advanced in list  
3. Make sure that Automatically Load Images, Enable Java, and 

Enable JavaScript are checked. 
 

Java 2.0 
 

Java 2.0 is the next step in quality for AudioClipstream.  It promises to 
deliver 8- and 16-bit audio data, in mono and stereo, with sample rates 
from 8 kHz to 48 kHz .  The significance of Java 2.0 will be realized in 
superior audio quality approaching CD reproduction.  However, this 
superior quality will be bandwidth intensive. 

 
The proliferation of Java 2.0, and its integration and support in 
AudioClipstream technology will be driven primarily by browser support 
(at time of publication, only Netscape 6 and the latest Opera browsers 
supported Java 2.0) and the availability of high bandwidth to the majority 
of web users. 

 
Browser / Email Compatibility Chart 
 

Operating 
System 

Browser  Email Client  

Windows 
95/98/NT/2000 

IE 3+ 
NN 2+ 
IBM Homepage Reader 
3.0 

OE 5.0 
Outlook 2000 
Netscape Messenger 
Eudora Pro 4.3 

Mac OS9 
OSX 

Netscape 4+ 
IE 4+  

Netscape Messenger 

Linux Netscape 3+ 
HotJava 1+ 

Netscape Messenger 

Solaris Netscape 3+ 
HotJava 1+ 

Netscape Messenger 
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Lotus Notes  
 

Overview 
 

We have experienced extensive problems with the compatibility of HTML 
in the Lotus Notes email viewer.  What we have seen or have had 
reported: 

 
•  HTML not appearing at all 
•  HTML improperly formatted or laid out 
•  HTML coding removed from the email, but applet code 

remaining 
•  HTML email not being able to be forwarded 
•  Applet not playing or appearing in email 
•  Images not appearing in HTML email 
•  Send to a friend function working, but producing errors 
•  Audio applet standard buttons can be forwarded, but custom 

sets produce error 
 

Since we have been unable to get in front of a prospects system to de-
bug first hand, we have downloaded beta release 5.0.8 from Lotus to test 
with.  The prospect is using version 5.0.3.  Version 5.0.8 was able to 
handle HTML emails and our products with a standard install, although we 
did encounter problems with custom button sets in the audio applet, and 
there were distinct formatting issues with Lotus.  It should be noted that 
our testing was done with the Notes client alone and not the Notes server, 
which could also be affecting the emails.  It should also be noted that 
HTML support in Lotus is a very new concept and at slight odds with the 
structure of their document and communications management system.   
 
Online help is minimal and not helpful.  Support calls have been placed to 
Lotus, and after a long run around, we found that we cannot get the 
answers we need (if they even exist) without paying a minimum of $2000 
US for a support package.  Our research has focused around the Lotus 
site, and Third party developer and discussion sites, with no official word 
from Lotus. 
 
It is possible that this problem does not have a solution that can be 
developed by Destiny.  We have not been able to test on the prospects 
system (5.0.3), thus all of our recommendations here are pure 
speculation.   

 
Possible Remedies  

 
Using Lotus Notes R5 Client Beta Release V.5.0.8 

 
•  Set the notes browser setting to use MSIE 
•  Change mail viewing preference to HTML and Plain Text, or 

No Preference 
•  Make sure you are running Server 5.0.3 or higher with bug 

fixes and updates (less than release 5 will not support 
HTML) 

•  Enable SMTP 8-bit MIME extensions on the server 
•  Make sure Domino Server is not set to Notes Rich Text 

Conversion 
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Outlook 

 
Crash on Close 
 

Outlook has a bug that causes it sometimes to crash when the email 
window containing AudioClipstream is closed. To reduce this risk, the 
website author or sender of the AudioClipstream email should insert the 
following tag into their <body>.  

<BODY onUnload="this.focus()" > 

This tag keeps the focus of the email client on the email window instead 
of the Java applet.  

 
Double Play 
 

In some instances a user will experience what they think is the 
AudioClipstream applet playing twice at the same time, doubling up, or 
echoing.  A clip set to auto play while outlook is using the email preview 
window usually causes this situation.  In this instance, when the user 
double clicks an email entry in their email list to open it, Outlook not only 
opens up a new window with the email message that auto plays, but it 
also populates the Outlook preview window with another instance of the 
applet which auto plays.  Hence, two versions of the same streaming 
audio clip will be playing simultaneously, in separate windows, out of 
sync.  This situation can be remedied in three ways: 

 
1. Turn off auto play in the source code of the message prior to 

emailing, 
 
2. Have users not use the preview functionality in Outlook, or 
 
3. Construct a multi-part email message that will recognize the non-

scripting capability of the preview window and display an 
alternate applet which is not set to auto play.  This fix option is 
much more complex to construct than a normal HTML email. 

 
Mac Issues 

 
 Memory 

 
The MacOS and its various hardware platforms (IMac, G3, G4, etc) 
introduce several playback compatibility issues, mostly due to the way 
Java is integrated (or not integrated, to be precise) into the MacOS, 
which is only aggravated by memory issues on the lower level hardware 
platforms.   
 
The primary problem is that the Java Virtual Machine, as it’s known in 
the PC world, is not resident in the browser or the MacOS from version 9 
and lower.  The MRJ requires at least 8 meg of available RAM for the 
System heap to expand into. This is *not* part of Internet Explorer’s 
memory partition. This is described by Apple TIL 22133, which can be 
viewed on the Web at: 

 
http://til.info.apple.com/techinfo.nsf/artnum/n22133 

http://til.info.apple.com/techinfo.nsf/artnum/n22133
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According to Apple: 

 
“MRJ may display error messages, fail to load images or fail to 
play sounds if there is not enough memory available to run, as 
described in the Memory Usage section above. In rare cases, 
MRJ may crash or hang if it cannot get enough memory to run.” 

 
Apparently, this problem is resolved in OS X.  
 

Version Specific Issues 
 
- Mac Netscape 4.5-4.61 has no Java streaming support and can cause 
the machine to crash hard. This is beyond our control but those versions 
are rarely used now.  
 
- Mac OSX is unsupported. We have reports of it working but have yet to 
track it down. We are actively working on this.  
 
Content owners streaming Clipstream may want to screen for those 
configurations and just provide some alternative instead of the applet 
code.  
 

Encoding Issues 
 

We offer Macintosh encoding software for AudioClipstream but 
VideoClipstream encoding for Mac is still unavailable. Note that there are 
currently some special considerations for users of the Mac Clipstream 
Compressor.  The compressor uses the exact same codec as the 
Windows Clipstream™ Audio Encoder but does not provide the latest 
Clipstream™ Audio applet. Here's the process: 
 

•  Download this clipstreampro.zip applet to use for your 
Clipstream files.  

•  use the applet code generator for Macintosh  
•  upload the clipstreampro.zip file, your html with the applet code 

and code key embedded in it, and the *.22 and *.44 audio files  
•  disregard mention of .20 and .32 files mentioned elsewhere in 

the help section. They are the actual bit rates of the .22 and .44 
files and are the new extensions used in the Windows version of 
the software  

•  Watch for the release of the Macintosh Clipstream™ Audio 
Encoder!  

 
Hotmail, Yahoo Mail 

 
Free web email viewers are widely used, but unfortunately, no substitute for a 
client based viewer that supports a wide range of presentation formats.  
Currently, free email packages such as Hotmail and Yahoo do not support java 
applets in their viewers, and either do not process the applet, or strip it out 
completely.  There are two things an AudioClipstream author can do. 
 
First, when the applet is not processed, make sure you edit the alternate 
messaging of the applet (see section Alternate Messaging) to point to another 
web location to hear the content.  This can be accomplished with a link or other 
mechanism. 

http://www.clipstream.com/img/buttonsets/csweather/clipstreampro.zip
http://www.clipstream.com/codegen/codegenMac.shtml
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Second, when the email viewer strips out the applet all together, you will need to 
provide a link outside the constraints of the applet to a place on the web where 
the audio can be heard.  Remember, this link cannot be placed between 
<APPLET> and </APPLET> or it will not be seen.  And also remember that the 
link will always show on the page, so be sure your design and placement is 
appropriate to the page. 
 
In addition, when linking from a package like Hotmail, the link will be opened in a 
separate framed window with Hotmail’s branding.  Some of your business clients 
will not want this.  To prevent this, place the following code into the <head> of the 
target HTML document to break out the frames: 

<script language="JavaScript"> 
<!-- 
if (parent.frames.length != 0) { 
  top.location.href=this.location; 
} 
// --> 
</script> 

 
Hosted Web Pages 

 
Free web pages hosted by sites such as Angelfire have a tendency to cause 
implementation problems due to restrictive server settings on file types such and 
.exe and .zip and in some instances, failure to support all non-registered file 
types. 
 
To implement on a system that will not serve or accept the .zip format is most 
common.  Hosting companies wish to prevent download sites form popping up 
and eating up their bandwidth.  This presents a problem for the 
audioclipstream.zip file, which will not be served from these systems.  Some 
minor alterations to the applet and the applet code can be made to make 
Clipstream work on these servers. 
 
Change the extension of audioclipstream.zip to audioclipstream.jar and upload it 
to the server. 
 

1. In the first line of the applet code change 
ARCHIVE=”audioclipstream.zip” to ARCHIVE=”audioclipstream.jar” 

2. Add a CODEBASE=”http://link to your site/” statement to the first line of 
the applet code. 

 
These minor changes should allow AudioClipstream to work on these sites. 
 
For systems that will not allow the upload of unregistered file types (the .20 and 
.32 files for instance), there is not much that can be done with the code to 
accommodate this.  You will need to contact the Network Administrator and have 
these file types permitted.

 

http://link to your site/
http://www.clipstream.com/help/emailhelp.shtml
http://www.clipstream.com/codegen/video_codegen_simple.shtml
http://www.clipstream.com/
http://www.dsny.com/
mailto:sales@clipstream.com
mailto:help@clipstream.com
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